All Forums Tools
bugmenot 8 posts Joined 03/11
26 Aug 2013
Installing the TTU 14.10 on windows

Dear All,
This is my first post on this forum. I have downloaded the teradata TTU 14.10 for windows. After having extracted the zip file i want to install the same. As per the instructions given here on the site it says i need to run the setup.exe to install it. But i dont find one single setup.exe which does this job,instead i find setup.exe in each and every folder such as BTEQ,FASTEXPORT,FASTLOAD. Do i need to install everything seperately. At the sametime there are 3 more exes such as TTU_Base.exe,TTU_DBM.exe and TTUListProducts.exe. Is there any order in which they need to be installed.Kindly let me know on this.

SuSeSi 61 posts Joined 10/08
04 Sep 2013

TTU_Base.exe is the program which can be used for all of the fastload/bteq/fastexport etc. You will be prompted with product to choose in a menu.
Note that when you install with TTU_Base.exe, you only will have one entry in add/remove program.
If you want to install individual packages separately then you can brawse and install.


bugmenot 8 posts Joined 03/11
14 Sep 2013

Dear Sudhansu,
Thanks a lot for the information. There is one more thing that i wanted to know.
When i install TTU_Base.exe, it will be installed on the windows OS.On the other hand the teradata express downloaded runs on SUSE linux and the whole thing is invoked using VMware Player. Now my question here is how will the TTU utilities running on windows interact with the database that is on SUSE linux. Your response is much appreciated.

M.Saeed Khurram 544 posts Joined 09/12
15 Sep 2013

TTU_Base.exe is the main setup file that you need to run and then you will choose the products you want to install. 
TTU_DBM.exe will install the database administration utilties. if you need admin utilities as well then install these as well.


bugmenot 8 posts Joined 03/11
15 Sep 2013

Hi Saeed,
Thanks for the response. But my question is , my teradata database is invoked using VMware player and my mload utility is installed on windows 7. In such a situation how can i load a file using mload utility. I am sorry if my question looks insensible as i am totally new to teradata.

M.Saeed Khurram 544 posts Joined 09/12
15 Sep 2013

oops, I am sorry for the misunderstanding. Well, it is very simple. You need to add ODBC connection to connect the VM.
Perform the following steps and you can access the Teradata installed on VM.

  1. First of al check the IP of machine on VM, by issuing ifconfig command.
  2. once you know the IP of the VM machine, go back to your machine and ping that IP of (VM), make sure you can acces it from your machine.
  3. Open the SQL Assistant installed on your machine and the go to the Tools menue -> Define ODBC data source.
  4. On ODBC window, Click on Add, choose Teradata from the next window
  5. Enter name of your choice as the connection name, Enter the IP of VM in the Teradata server info.
  6. Enter user name and password, click ok, You are done with the connection.

Now in SQL Assistant on the top left click on the Connect button, and from machine data source tab, select your ODBC name you just added.
Click Ok, and you will get connected to the Teradata on VM. Now you can submit queries!


bugmenot 8 posts Joined 03/11
16 Sep 2013

Dear Saeed,
Wow Wow !!! Thanks a ton Saeed it is working now. I was totally confused as to how to go about.
Well anyways my name is suresh rangadhamaiah and an australian resident. My email id is
Have a great time!!

wolf75 1 post Joined 06/13
18 Sep 2013

Installation of SQLAssistant on Win 8 64x fails with message "Error 1606. Could not  access network location 0\Teradata\SQL Assistant".

M.Saeed Khurram 544 posts Joined 09/12
18 Sep 2013


The problem is potentially a result of an inconsistent/incorrect environmental variable (%AppData%).



  1. Open the Registry editor
  2. Navigate to the following registry keys HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  3. The correct and default value for AppData should be: %USERPROFILE%\AppData\Roaming
  4. Close the Registry editor, and try again Windows Update again. (A reboot should not be required.)
  5. If the problem persists, repeat the steps 2 through 4 with the following registry keys:


HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\


Hope this will work for you!



Khurram 4 posts Joined 04/15
14 Apr 2015

Hi Saeed,
I am installing TTU 15.0 on Windows x64. I have 3 exe files with me. TTU_Base, TTU_DBM & TTUListProducts.
Can you please clarify one thing that what should be the sequence to install these 3 applications & what is the purpose of these 3 ? Do I need to install SQL Assistant exclusively or it will be a part of ant of these installs.
Thanks a lot.
Aashish Kumar

cr255014 23 posts Joined 01/14
16 Apr 2015

SQLA is a part of TTU Base. When you Install TTU Base a list of packages will be displayed from which you need to check the ones you would want to use and One of them is SQLA.

RamyaDaniel 1 post Joined 08/15
18 Aug 2015

Hi All,
I tried to install Teradata15. When I tried to download TTU_Base.exe I get the below error message.
"The package your trying to install requires a file that is not available. To continue, specify an alternate path to this file.
setup.exe "
I did unzip the folder, not sure on this error message.

swethamohan 1 post Joined 08/15
19 Aug 2015

I too tried installing Tera data. It shows error. what can i do? Can anyone help me....

heavyarms 1 post Joined 05/10
03 Sep 2015

Trying to install SQL Assistant 14.10 - Install fails with [ Error 1606.Could not access network location 0\Teradata\SQL Assistant. ] 
I have tried fully uninstalling and installing, rebooting, trying the registry fixes mentioned above. Tried Installing Version 15 package instead (same error). I'm running out of ideas, all of the other components install fine. but SQL Assistant is proving to be the show stopper.  Any ideas are welcome.
Here are is the install log that speaks to the issue.
MSI (s) (88:E0) [14:14:05:981]: PROPERTY CHANGE: Adding GlobalAssemblyCache property. Its value is 'C:\'.
MSI (s) (88:E0) [14:14:05:981]: PROPERTY CHANGE: Adding CommonShCutDir property. Its value is 'C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Teradata Client 15.00\'.
MSI (s) (88:E0) [14:14:05:981]: PROPERTY CHANGE: Adding newfolder1 property. Its value is 'C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Teradata Client 15.00\Teradata SQL Assistant\'.
MSI (s) (88:E0) [14:14:05:981]: PROPERTY CHANGE: Adding MSShared property. Its value is 'C:\Program Files (x86)\Common Files\Microsoft Shared\'.
MSI (s) (88:E0) [14:14:05:982]: PROPERTY CHANGE: Modifying ALLUSERSPROFILE property. Its current value is 'C:\ProgramData'. Its new value: 'C:\ProgramData\'.
MSI (s) (88:E0) [14:14:05:982]: Note: 1: 1314 2: 0\Teradata\SQL Assistant
MSI (s) (88:E0) [14:14:05:982]: Note: 1: 1606 2: 0\Teradata\SQL Assistant
Error 1606.Could not access network location 0\Teradata\SQL Assistant.
MSI (s) (88:E0) [14:14:19:603]: Product: Teradata SQL Assistant -- Error 1606.Could not access network location 0\Teradata\SQL Assistant.

GNS 4 posts Joined 09/15
09 Sep 2015

I have installed TTU After the installation I have tested to run some workflows and I am getting the error below:
Message Code: TPTWR_35132

Message: [ERROR] Plug-in failed to load Teradata Parallel Transporter API Library.


I have already entered the environment variables but it seems I am missing something


Can you tell me which are the Environment variables I have to add on Windows?

You must sign in to leave a comment.