All Forums Database
realrx7 17 posts Joined 06/12
21 Jun 2012
CREATE TABLE Failed [3737] Name requires more than 30 bytes in LATIN internal form???

Here is what I have that is causing the error........

 

CREATE MULTISET TABLE DLAB_MARKETING.Click,

NO FALLBACK,

NO BEFORE JOURNAL,

NO AFTER JOURNAL,

CHECKSUM = DEFAULT,

DEFAULT MERGEBLOCKRATIO

(

AccountID INTEGER,

OYBAccountID INTEGER,

JobID INTEGER,

ListID INTEGER,

BatchID INTEGER,

SubscriberID INTEGER,

SubscriberKey VARCHAR(100),

EventDate DATE,

URL VARCHAR(900),

LinkName VARCHAR(1024),

LinkContent VARCHAR(1000),

TriggeredSendDefinitionObjectID VARCHAR(36),

TriggeredSendCustomerKey VARCHAR(36)

)

PRIMARY INDEX (AccountID);

Dixxie 53 posts Joined 12/10
21 Jun 2012

Hi realrx7, 

Te problem is with the column name TriggeredSendDefinitionObjectID , this has more than 30 characters.

3737 - Name is longer than 30 characters.

Regards.

realrx7 17 posts Joined 06/12
21 Jun 2012

Thanks!!

ersin.gulbahar 3 posts Joined 06/13
14 Jul 2013

Hi my table name is 26 characters and my column names are not more than 30 chars.
but I got this error :[Error 3737] [SQLState 42000] Name requires more than 30 bytes in LATIN

dnoeth 3361 posts Joined 11/04
14 Jul 2013

 

Your tablename is probably too long, when you check http://developer.teradata.com/doc/connectivity/jdbc/reference/current/jdbcug_chapter_2.html#BABIIEAG you'll find
JDBC FastLoad creates two temporary error tables with the following naming convention: ._ERR_1 and ._ERR_2
and
The name of the destination table in the Teradata Database that is to be used by JDBC FastLoad CSV must not exceed 24 characters because of the name of the two error tables created by JDBC FastLoad CSV
If this was a standard FastLoad i would simply add ERRORTABLES and use my own error table names, but this seems not to be available in JDBC FastLoad. So your only option is to create the table with a shorter name, FastLoad it and thensubmit a RENAME TABLE.
 
Dieter

 

Dieter

Sourabh_Rox 2 posts Joined 08/13
30 Aug 2013

My Largets column name is 29 char long. still i am facing the same error.
SELECT Failed 3737: Name requires more than 30 bytes in LATIN internal form.
thanks.

dnoeth 3361 posts Joined 11/04
30 Aug 2013

Based on the error message this seems to be a SELECT, could you show it (or at least the column names/aliases used)?
 
Dieter

Dieter

srilamaiti 3 posts Joined 07/10
2 weeks ago

I have a table named TN_ORDERLINE_DEPENDENCY_TYPE_LNDG. None of its columns are more than 30 characters. I am able to create the table in one environment while it;s failing in other. Both the environments have TD release of 14.10.03.06. Can you please suggest what might be different in two environments?

Harpreet Singh 98 posts Joined 10/11
2 weeks ago

your tablename is more than 30 char.TN_ORDERLINE_DEPENDENCY_TYPE_LNDG .. please reduce below 30 and then create in both env. then let know if still issues

ulrich 768 posts Joined 09/09
2 weeks ago

@Srilamaiti 
You should open a new discussion for a new topic.
On the different behaviour between two systems both on 14.10:
14.10 is long object name enabled - this means dbc tables and V views can store long object names - up to 128 chars.
But you can set dbc control fields to NOT allow this. 
And this is disabled for systems which are upgraded from older releases but is enabled by default for new systems where a sysinit had been performed.
Could it be that one of your systems was upgraded (e.g. the production box) and one was delivered with 14.10?
 

Der Beginn aller Wissenschaften ist das Erstaunen, dass die Dinge sind, wie sie sind.-Aristoteles

david.craig 40 posts Joined 05/13
2 weeks ago

The DBS Control settings referenced by Ulrich are: EnableEON, NameValidationRule, and LanguageSupportMode. It is possible to enable Globalization rule naming during an upgrade.
Please see the Orange book: 'Teradata Extended Object Names' which covers these areas in more detail.
 
Thanks,
-David

You must sign in to leave a comment.