All Forums Database
m.tahoon 40 posts Joined 09/11
12 Jul 2012
CLI error: MTDP: EM_GSSINITFAIL(235): call to gss_init failed

GSS TTU 13.10 installation problem:

this is Suse linux server
# uname -a
Linux ViewPoint_00-16 #1 SMP Thu Nov 10 04:53:43 PST 2011 x86_64 x86_64 x86_64 GNU/Linux

Logon to Bteq returns the following error:

# bteq

Teradata BTEQ for LINUX.
Copyright 1984-2011, Teradata Corporation. ALL RIGHTS RESERVED.
Enter your logon or BTEQ command:
.logon SYS6690/u_script

.logon SYS6690/u_script

*** CLI error: MTDP: EM_GSSINITFAIL(235): call to gss_init failed.
*** Return code from CLI is: 235
*** Error: Logon failed!

TTU required by bteq installed:
# rpm -q TeraGSS_suselinux-x8664-

# rpm -qa | grep cliv2

# rpm -qa | grep tdicu

# rpm -qa | grep piom

# rpm -qa | grep bteq

Let me know fi i missed any point here.

CarlosAL 401 posts Joined 04/08
12 Jul 2012


What is your LD_LIBRARY_PATH variable? ( echo $LD_LIBRARY_PATH )



m.tahoon 40 posts Joined 09/11
12 Jul 2012

Problem solved

I've used 64-bit binary for TDGSS, cliv2, tdicu with 32-binary for bteq (no 64 for bteq exist).

Using 32-bit for all binaries fixed the issue.

Best regards

Hal 1 post Joined 03/09
12 Apr 2013

Had the same problem. If you look at strace for bteq it is trying to find the fileĀ /usr/teragss/linux-i386/client/etc/tdgssconfig.bin.
I had the fileĀ /usr/teragss/linux-i386/client/etc/tdgssconfig.bin.prebuilt file so I just renamed it and everything worked fine.

esrkreddy 1 post Joined 09/13
10 Jan 2014

thanks a ton. this worked.
I put the file in /usr/teragss/linux-x8664/client/etc/tdgssconfig.bin and it worked. :)

TSchmolzi 30 posts Joined 07/07
13 Feb 2015

What would be the corresponding location on a WS2008 R2 server?

- Tim S

You must sign in to leave a comment.